READ THIS – if you get 500 errors, white pages (htaccess errors)

Fast, Effective WordPress Plugins, Scripts and Themes Forums PHPValley Scripts & Plugins PHPValley Micro Jobs Site Script READ THIS – if you get 500 errors, white pages (htaccess errors)

This topic contains 2 replies, has 2 voices, and was last updated by PHPValley Answers PHPValley Answers 4 years, 1 month ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #2894

    First make sure you set the directory correctly if you have installed the site under a subdirectory. Like, http://domain.com/subdir – in that case “RewriteBase /” must be changed to “RewriteBase /subdir/”. There must be 1 space in between “RewriteBase” and the “/”.

    If you still have issues, change the “Options +SymLinksIfOwnerMatch” to “Options +FollowSymLinks”

    If this doesnt fix your issue, then try adding “/” in front of rules – like : “RewriteRule ^tags-(.*)/ tags.php?keyword=$1” to “RewriteRule ^/tags-(.*)/ tags.php?keyword=$1”

    If you still are having issues, then come and post your htaccess in the forum in a ! NEW TOPIC !.

    Default htaccess would be like the below:

    Options +SymLinksIfOwnerMatch
    Options -MultiViews
    RewriteEngine on

    RewriteBase /

    RewriteRule ^tags-(.*)/ tags.php?keyword=$1
    RewriteRule ^tags-(.*) tags.php?keyword=$1
    RewriteRule ^profile-(.*)/ profile.php?username=$1
    RewriteRule ^profile-(.*) profile.php?username=$1
    RewriteRule ^category-(.*)/ category.php?cat=$1
    RewriteRule ^category-(.*) category.php?cat=$1
    RewriteRule ^(.*)-([^-]+)\.html jobs.php?id=$2
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME}\.php -f
    RewriteRule ^(.*)$ $1.php
    RewriteRule ^([a-z]{2})(?:/)?$ index.php?lang=$1 [NC]

    #2985

    steverob
    Participant

    Hi – getting this error:
    “MySQL error: Could not connect to database. Access denied for user ‘sean’@’localhost’ (using password: NO)”

    I don’t recognise “sean” – no idea where that came from – it has no relation to the user name I created for the DB. Have created this site as a subdomain, installed the script in the subdomain folder, have created DB, DB user all privileges just as instructed. Have made the changes to the .htaccess file as suggested – still getting this connection problem.

    #2990

    there may be a htaccess rewriting scheme redirecting your requests.

    however first, go to your host control panel to see whether the database is created properly, user assigned properly and they work.

    it shouldnt try to use any other username pass than what you supplied in the install panel.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

Comments are closed, but trackbacks and pingbacks are open.